Ppmjasperadmin user not found in Jaspersoft
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Ppmjasperadmin user not found in Jaspersoft

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Article ID: 224795

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

“User ppmjasperadmin not available in report server. Resource ppmjasperadmin not found. code:resource.not.found  parameter:["ppmjasperadmin"]”  in the admin logs.

"Create and Update Jaspersoft Users" completes, but processes no users. An error is logged in the bg logs stating that "role_resource_designer" doesn't exist.

Environment

Release : 15.9.2

Component : Clarity Install and Upgrade

Cause

A new Jaspersoft application server has been set up, but the Jaspersoft content has not been imported.

Resolution

On the Clarity server, run this command to import the Jaspersoft content:

admin content-jaspersoft csk -userName superuser -password <password>

If this message is received:

Cannot import content on same release, use force flag to import. Skipping import.

If command: admin content-jaspersoft csk -userName superuser -password superuser upgrade force 
has same error, run the command using the operating system user account used to install Jaspersoft.

This would mean that Jaspersoft had been previously installed for the environment, but perhaps into a different Jaspersoft install.
In order to complete the required import, the references to the previous install needs to be removed. To do this access the database server and do the following:

1. Make a backup of the table: CMN_INSTALL_HISTORY 

2. Run a command to remove the references to Jaspersoft:

Delete from CMN_INSTALL_HISTORY where install_id like '%jasper'%;

3. Try to run the previous admin command again to import the default content.

Additional Information

Please ensure a database backup is completed prior to making any change directly to the database to avoid the risk of data loss.