We are unable to upgrade the robot via robot_update on a Linux Ubuntu 20.04 machine

book

Article ID: 224793

calendar_today

Updated On:

Products

DX Infrastructure Management CA Unified Infrastructure Management for z Systems CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) NIMSOFT PROBES

Issue/Introduction

We are not able to configure probes on an Ubuntu 20.04 machine. We need to update the Ubuntu 20.04 robot from robot version 9.31 to 9.33 but the robot update is failing.

robot_update distribution fails whether using IM-distsrv or AC-ADE to distribute the package.

The robot_update 9.33 and robot_deb 9.33 packages are in place in the local archives for robot v9.33 on the Primary hub as well as the remote hub that the robot reports to.

distsrv.log

Sep 23 13:46:39:167 [140492810133568] 0 Controller:   machine:  x86_64
Sep 23 13:46:39:167 [140492810133568] 0 Controller: Could not figure out what Linux version you are running!
Sep 23 13:46:39:167 [140492810133568] 0 Controller: Please report the following system information to [email protected]
Sep 23 13:46:39:167 [140492810133568] 0 Controller: System information:
Sep 23 13:46:39:167 [140492810133568] 0 Controller:   sysname:  Linux
Sep 23 13:46:39:167 [140492810133568] 0 Controller:   node   :  xxxxxxxx
Sep 23 13:46:39:167 [140492810133568] 0 Controller:   release:  5.4.0-77-generic
Sep 23 13:46:39:167 [140492810133568] 0 Controller:   version:  #86-Ubuntu SMP Thu Jun 17 02:35:03 UTC 2021
Sep 23 13:46:39:167 [140492810133568] 0 Controller:   machine:  x86_64
Sep 23 13:46:39:167 [140492810133568] 0 Controller: Could not figure out what Linux version you are running!
Sep 23 13:46:39:167 [140492810133568] 0 Controller: Please report the following system information to [email protected]

Cause

- New installation required.

Environment

Release : 20.3

Component : UIM - ROBOT

- robot v9.31

Resolution

Robot 9.33 is the first supported robot for Ubuntu version 20.04. So, UIM robot v9.33 MUST be freshly installed on Ubuntu 20.04.
 
 
Then, when applying any hotfixes above 9.33 like 9.33HF1 and so on, it will support the robot_update package distribution.