Attempting to load a lower version CAU throws | Cannot install Pack

book

Article ID: 224745

calendar_today

Updated On:

Products

CA Automic One Automation

Issue/Introduction

After installing CAU for UNIX Agent 12.3.6 -- PCK.AUTOMIC_CAU_AGENT_UNIX, some issues came up that required that the agents be downgraded.  When attempting to load the 12.3.5+hf3 CAU for UNIX, PCK.AUTOMIC_CAU_AGENT_UNIX 12.3.5, the following error occurs:

Cannot install Pack PCK.AUTOMIC_CAU_AGENT_UNIX 12.3.5, a higher version (12.3.6) was already installed on this client

Environment

Release : 12.3

Component :

Resolution

the only way to get around this error:
Cannot install Pack PCK.AUTOMIC_CAU_AGENT_UNIX 12.3.5, a higher version (12.3.6) was already installed on this client

is to remove the 12.3.6 CAU package.  This can be done with the following steps:

  1. Go into Client 0, then to the Administration, and Packs
  2. Right-click on the currently installed CAU Pack,  PCK.AUTOMIC_CAU_AGENT_UNIX and choose Remove
  3. Confirm the removal of the currently installed Pack
  4. Install the previous Pack using the "Install from File" button