9.02 Bundle CABI Upgrade to 20.3 fails - wasp error - Cannot obtain connection string from data_engine

book

Article ID: 224527

calendar_today

Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES CA Unified Infrastructure Management On-Premise (Nimsoft / UIM)

Issue/Introduction

9.02 Bundle CABI upgrade to 20.3 fails with errors below

Cabi.log:

[main, cabi] Running installation sequence since this is either a fresh install or an upgrade
[main, cabi] dataEngine is not explicitly specified so will try to locate the same from the hub hierarchy.
[main, cabi] dataEngine is not explicitly specified so will try to locate the same from the hub hierarchy.
[main, cabi] (521) , (80) Session error, Unable to open a client session for %UIMServerIP%:48035: Connection timed out: connect: Unable to open a client session for %UIMServerIP%:48035

Wasp.log:

[main, com.nimsoft.nimbus.NimProbeBase] Login to NimBUS is OK
[main, com.nimsoft.nimbus.probe.service.wasp.WaspNimProbe] WaspNimProbe login successful.
[main, com.nimsoft.nimbus.probe.service.wasp.Probe] Connection String:...
[main, com.nimsoft.nimbus.probe.service.wasp.Probe] Cannot obtain connection string from data_engine
[main, com.nimsoft.nimbus.probe.service.wasp.Probe] (80) Session error, Unable to open a client session for %UIMServerIP%:48035: Connection timed out: connect
 at com.nimsoft.nimbus.NimNamedClientSession.<init>(NimNamedClientSession.java:37)
 at com.nimsoft.nimbus.NimObjectSender.connectNamed(NimObjectSender.java:78)
 at com.nimsoft.nimbus.NimRequest.sendImpersonate(NimRequest.java:253)
 at com.nimsoft.nimbus.NimRequest.send(NimRequest.java:219)
 at com.nimsoft.nimbus.probe.service.wasp.Probe.getConnectionStringFromDE(Probe.java:944)
 at com.nimsoft.nimbus.probe.service.wasp.Probe.doit(Probe.java:307)
 at com.nimsoft.nimbus.probe.service.wasp.Probe.main(Probe.java:115)
Caused by: java.net.ConnectException: Connection timed out: connect
 at java.net.DualStackPlainSocketImpl.connect0(Native Method)
 at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlai

Cause

Presence of JAVA_JRE 2.07

Environment

Release : 20.3

Component : UIM - CABI

Resolution

Deployed JAVA_JRE 2.06 over existing version, 2.07, on the CABI robot and restarted the CABI install