WCC services going down
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WCC services going down

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Article ID: 224384

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Updated On:

Products

CA Workload Automation AE - Scheduler (AutoSys)

Issue/Introduction

Our WCC services on UAT hosts are going down unexpected without any clear indication nor crash.

Environment

Version 11.3.6 and 12.x

Autosys
WCC

Cause

From the log files we see that WCC receives a SHUTDOWN command on the shutdown port:

   CA-wcc.log

INFO   | jvm 1    | 2021/09/02 01:57:35 |    22580 | INFO: A valid shutdown command was received via the shutdown port. Stopping the Server instance.

    CA-wcc_services.log

INFO   | jvm 1    | 2021/09/02 01:57:30 |    22576 | INFO: A valid shutdown command was received via the shutdown port. Stopping the Server instance.

Resolution

WCC received a shutdown request through the shutdown port 8005. 

Disabling the shutdown port using the following steps:

1. cd $CA_WCC_INSTALL_LOCATION/tomcat/conf
    cp -p server.xml server.xml_original
    vi server.xml

    and search for the following line (in my server.xml it is on line 13

<Server port="8005" shutdown="">

    port 8005 is the default port number that has been chosen at installation time.
    It might be different in your environment.

    Change port "8005" to "-1". 

    This will disable that someone might perform a shutdown of the tomcat using that port number
    However, you will be still able to stop/start WCC services using the command "unisrvcntr"

2. cd $CA_WCC_INSTALL_LOCATION/tomcat_32/conf

             # for r12 release, there is no such option, so no need to follow this step for 12.x

    cp -p server.xml server.xml_original
    vi server.xml

    and search for the following line (in my server.xml it is on line 14

<Server port="10133" shutdown="">

     Change the port to "-1".

Stop/start the CA-wcc and CA-wcc-services.