ARD Studio User unable to save flow
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ARD Studio User unable to save flow

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Article ID: 224376

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Updated On:

Products

CA Agile Requirements Designer

Issue/Introduction

User can not save as an existing flow after small modification on it under another name on ARD Hub and ARD client freezes after click on save as button
 
Steps:
 
1- Open ARD desktop Client.
2- Login to ARD hub from client
3- Try to open any saved flow in a project.
4- Make a small change in the flow then save the new modification in the ARD hub under a new name in the same folder
5- Click on save as in the provided box
 

Actual result:
 
1- The ARD desktop client freezes and nothing happens and the user should close the whole client or close the action
 
Expected result:
 
1- The user should be able to save as the modified file under a new name if he is an editor or admin
 
 

Environment

Agile Requirements Designer all supported releases.

Cause

When investigating the issue with Process Monitor open for ARD Desktop client, could see that two DLLs from Microfocus UFT software are conflicting with ARD.

Resolution

This is not a product defect and is specific to customer environment where ARD and Microfocus products are running together.

It cannot be fixed from Broadcom ARD side as we have not have licenses or support agreement with MicroFocus to contact and discuss such issues. 

However, looking at the issue, below inputs are shared which may help customer team(s) to get it fixed from MF-UFT side.

- UFT appears to be a windows application UI testing tool which works by intercepting interaction events (i.e. clicks, key strokes, drags, drops etc.) through a series of injected DLLs. ARD has been built by using the third party QT library. QT library does not fully conform with the general Windows event architecture. Because of this, UFT ends up "poisoning" the event loop of ARD, instead of just quietly intercepting it. This cannot be fixed in ARD.

- It is "expected" that UFT has a method of whitelisting/exempting applications from monitoring and that might be the key in making them work together. Customer can work with UFT SMEs and UFT support that would be able to do that.