No suitable driver found for jdbc:oracle:thin error when opening Database Browser
search cancel

No suitable driver found for jdbc:oracle:thin error when opening Database Browser

book

Article ID: 224311

calendar_today

Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Opening the Applications Manager Database Browser may result in the below error:

 java.sql.SQLException: No suitable driver found for jdbc:oracle:thin:@//master.hostname.example:1521/AMMASTER

Environment

Release : 9.3.x

Component : APPLICATIONS MANAGER

Cause

Ojbc*.jar driver found in $AW_HOME/web/classes may be incompatible

Resolution

Solution:

Ensure the ojdbc*.jar version in the $AW_HOME/web/classes directory or %AW_HOME\web\classes (Windows) directory is the most suitable version for the Oracle Client/Server versions. Refer to Oracle if needed.

A restart of Applications Manager processes or service (Windows) is required to register any jar file changes.

Workaround:

If the issue still exists, copy the ojdbc*.jar file from the $AW_HOME/web/classes directory or %AW_HOME\web\classes (Windows) directory to the Client PC's jars directory. This needs to be done on all clients. The jars directory is located in the same directory as the RunClient.jar file.

Additional Information

Applications Manager version 9.4.2 introduced a change where the ojdbc*.jar is loaded into client java process before Launching so a oracle driver is no longer needed in the client's jar directory.