Protection Engine LiveUpdate fails - "Failed to select server"
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Protection Engine LiveUpdate fails - "Failed to select server"

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Article ID: 224023

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Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

Symantec Protection Engine (SPE) LiveUpdate fails. The lux.log (located at <install dir>\definitions\Stargate\log) contains the following error:

FAIL - failed to select server

Longer snippet:

13:30:35.795062 [Server Selection - START]
13:30:39.810682  Result Code: 0x80010830
13:30:39.810682  Result Message: FAIL - failed to select server
13:30:39.810682  [Server - START]
13:30:39.810682   Host ID: {CCC8801C-AD14-4364-AA61-7F79502BD8FE}
13:30:39.810682   Status Code: 1
13:30:39.810682   Status Message: Server was not selected
13:30:39.810682   Transport Return Code: 0x80010731
13:30:39.810682   Transport Return Message: FAIL - download failed
13:30:39.810682   Protocol: HTTP
13:30:39.810682   Hostname: liveupdate.symantec.com
13:30:39.810682   Port: 80
13:30:39.810682   Path: 
13:30:39.810682   Proxy ID: {A6F13B1C-CDFD-411B-BCFF-EE81A752824E}
13:30:39.810682   Proxy Bypass: false
13:30:39.810682  [Server - END]
13:30:39.810682  [Proxy - START]
13:30:39.810682   Proxy ID: {A6F13B1C-CDFD-411B-BCFF-EE81A752824E}
13:30:39.810682   Protocol: HTTP
13:30:39.810682   Default: NONE
13:30:39.810682   Host: <proxyaddress>
13:30:39.810682   Port: <proxyport>
13:30:39.810682  [Proxy - END]
13:30:39.810682 [Server Selection - END]

Cause

This error indicates a failure to connect to the configured update server. By default, this is liveupdate.symantec.com

Resolution

The following steps can be used to troubleshoot the issue:

  • If your environment requires a proxy, ensure SPE is configured to update through a proxy.
  • Ensure both proxy and firewall are configured to allow communication to your configured update server (normal liveupdate.symantec.com) on your configured port (normally 80 or 443 depending on the selected protocol)

 

To troubleshoot connectivity to LiveUpdate

  1. In a browser windows, navigate to:
    https://liveupdate.symantec.com/livetri.zip
  2. If the browser displays an error instead of downloading livetri.zip, check logs of the proxy shown in the Settings of the browser.

 

To confirm the proxy settings of SPE

  1. In a cmd or bash prompt, navigate to the installation folder of SPE
  2. To display the SPE settings related to proxy, type the four following commands (is case sensitive):
    ./XMLModifier -q /configuration/ProxyServerSettings/ServerName/@value configuration.xml
    ./XMLModifier -q /configuration/ProxyServerSettings/ServerPort/@value configuration.xml
    ./XMLModifier -q /configuration/ProxyServerSettings/UserName/@value configuration.xml
    ./XMLModifier -q /configuration/ProxyServerSettings/Password/@value configuration.xml
  3. Compare these settings against the browser settings of a browser where download of livetri.zip succeeded.
  4. Check the logs of the proxy for the IP address of the machine where you conducted these tests.
  5. If needed, refer to the Networking Ports requirement topic in the SPE online help, here

Additional Information

Proxy and Quarantine Server Settings

How to configure SPE 7.8 and newer to download definitions through a proxy