TDM Portal fails to upgrade, Installer hangs
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TDM Portal fails to upgrade, Installer hangs

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Article ID: 224000

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

I'm in the process of upgrading my TDM Web Portal to version 4.9.345 from Broadcom support. The file was extracted and installed on one of the servers. 

However, when I tried to install(upgrade) it on one of the test servers (after restarting the server, after installing (upgrading) both GTDatamaker and GTSubset), the CA Test Data Manager services were now shown as 'existing' and the installer hangs on this screen:

Environment

TDM Portal 4.9.x

Cause

We are missing the CA Test Data Manager Portal service, the OrientDB service, and the %AppDaat%\CA\CA Test Data Manager Portal files. It appears some files and services were deleted from the system, leaving the application installation in an odd state.

Resolution

 

If this server is a VM, and a snapshot was taken prior to the failed upgrade attempt, it's recommended to restore the snapshot, and try running the upgrade again.

If a snapshot was not taken, the recommendation is to:

  1. Back up the following files:
    • %ProgramData%\CA\CA Test Data Manager Portal\orientdb\databases directory
    • %ProgramData%\CA\CA Test Data Manager Portal\objects directory
    • %ProgramData%\CA\CA Test Data Manager Portal\Jobs directory (optional)
    • %ProgramData%\CA\CA Test Data Manager Portal\classifiers directory (optional)
    • %ProgramFiles%\CA\CA Test Data Manager Portal\conf directory.

      This will allow us to save a copy of the OrientDB database files, imported classifiers, Jobs, and the TDM Portal configuration files.
      Note: be sure you have the credential needed to re-establish a connection to your gtrep repository database.

  2. Uninstall of TDM Portal

  3. (Optional) Reboot the server

  4. As Administrator, run a fresh install of the TDM Web Portal install media.
    Be sure to uncheck the Start Portal option, so we do not automatically start the CA Test Data Manager Portal service when the installation completes.

  5. Once Portal is reinstalled, we would need to stop the OrientDB service.

  6. Restore the following files from your backup that you made:
    • %ProgramData%\CA\CA Test Data Manager Portal\orientdb\databases
    • %ProgramData%\CA\CA Test Data Manager Portal\objects directory
    • %ProgramData%\CA\CA Test Data Manager Portal\Jobs directory (optional)
    • %ProgramData%\CA\CA Test Data Manager Portal\classifiers directory (optional)

  7. Restart OrientDB service

  8. Restart the CA Test Data Manager Portal service.

  9. Launch the TDM Web Portal UI and verify the Portal is accessible and functioning properly.