Sysprep runs causing boot loop after image deploy with DeployAnywhere enabled
search cancel

Sysprep runs causing boot loop after image deploy with DeployAnywhere enabled

book

Article ID: 223962

calendar_today

Updated On:

Products

Ghost Solution Suite Deployment Solution

Issue/Introduction

Customer is deploying a Sysprep image with DeployAnywhere enabled.

When destination machine boots up after imaging, Sysprep runs with the following window displayed:

If "Cancel" is selected, the endpoint reboots then exhibits the same behavior when it comes back up.

Environment

Windows

Sysprep

GSS 3.x

DeployAnywhere

Cause

In at least one case, the issue was caused by a failed run of DeployAnywhere. When looking at the DA logs we see the following:

-------Ghost::DA::WinDeviceDriverRetargeterWin32::PreInstallNonCriticalDeviceDrivers():5107

The retargeting operation of non-critical devices has completed successfully.

Sysprep is running

Setting up mini-setup and HAL...


 DefaultPassword not found

 

 DefaultPasswordEntry not found


PROFILE::Operation -> 'mSymPrep->Retarget', elapsed time (ms): 31

PROFILE::Operation -> 'Retarget', elapsed time (ms): 165421

Error while retargeting the system.

 

Error while retargeting the system.

 Error: Registry key %1 not found on system. target_software\\Microsoft\Windows NT\CurrentVersion\RegisteredOwner

End of DeployAnywhereMain().

DA Return code is 3(GH_ERROR).

 

So, DA starts Sysprep mini-setup and HAL to inject drivers. However, this fails because of the following error:
Error: Registry key %1 not found on system. target_software\\Microsoft\Windows NT\CurrentVersion\RegisteredOwner

When checking the registry in the image, it is confirmed the string exists in the key but doesn't have a string value.

Resolution

Use the default .xml answer file selection in the Distribute Disk Image task or use an answer file that configures 'RegisteredOwner' in the Specialize pass.

Sample answer files are included with Ghost Solution Suite and are located in the 'Sysprep' and 'Samples' folders. Default answer files are located in the 'Deploy' folder. It is recommended to only modify copies of these files and preserve the originals.

For instructions on modifying or creating Sysprep answer files, refer to Microsoft documentation.

Alternatively, modify HKLM\Microsoft\Windows NT\CurrentVersion\RegisteredOwner regkey in the image before deploying the image with DA enabled.