Sysprep runs causing boot loop after image deploy with DeployAnywhere enabled
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Sysprep runs causing boot loop after image deploy with DeployAnywhere enabled

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Article ID: 223962

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Updated On:

Products

Ghost Solution Suite Deployment Solution

Issue/Introduction

Customer is deploying a Sysprep image with DeployAnywhere enabled.

When destination machine boots up after imaging, Sysprep runs with the following window displayed:

If "Cancel" is selected, the endpoint reboots then exhibits the same behavior when it comes back up.

Environment

Windows, Sysprep

Cause

In at least one case, the issue was caused by a failed run of DeployAnywhere. When looking at the DA logs we see the following:

-------Ghost::DA::WinDeviceDriverRetargeterWin32::PreInstallNonCriticalDeviceDrivers():5107

The retargeting operation of non-critical devices has completed successfully.

Sysprep is running

Setting up mini-setup and HAL...


 DefaultPassword not found

 

 DefaultPasswordEntry not found


PROFILE::Operation -> 'mSymPrep->Retarget', elapsed time (ms): 31

PROFILE::Operation -> 'Retarget', elapsed time (ms): 165421

Error while retargeting the system.

 

Error while retargeting the system.

 Error: Registry key %1 not found on system. target_software\\Microsoft\Windows NT\CurrentVersion\RegisteredOwner

End of DeployAnywhereMain().

DA Return code is 3(GH_ERROR).

 

So, DA starts Sysprep mini-setup and HAL to inject drivers. However, this fails because of the following error:
Error: Registry key %1 not found on system. target_software\\Microsoft\Windows NT\CurrentVersion\RegisteredOwner

When checking the registry in the image, it is confirmed the string exists in the key but doesn't have a string value.

Resolution

Modify HKLM\Microsoft\Windows NT\CurrentVersion\RegisteredOwner regkey in the image before deploying the image with DA enabled.

To modify the registry in the image, the following KB assisted:
https://knowledge.broadcom.com/external/article/151769

In this particular case, the Software file needed to be extracted rather than "System" which is documented in that KB.