CAWA DB agent installed but not working
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CAWA DB agent installed but not working

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Article ID: 223945

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Updated On:

Products

CA Workload Automation DE - Scheduler (dSeries) CA Workload Automation DE CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

User has installed/added plugin to the agent and defined a user (e.g. USER1234) with the plugin. When a job is executed with same user in job definition, USER1234, the following error is displayed in Desktop Client:

User USER1234 not defined in Agent AGENT_DB.

 

Environment

Release : 12.2

Component :

Cause

Define the user that is used in job at Agent level in DE (dSeries) as well.

Resolution

If a user is defined at job level, then user must be added to the agent.  The user in agent means, go to Topology, open the agent and add user there.  Any user defined in the DE job must be in agent Topology because DE sends user/password to the agent.  Multiple users may be define in Topology for different jobs and agent will override its own user by using the user and password that DE sends to it.

Note: If the job comes to agent without any user, then it will use default user that has been defined at agent side.  For UNIX/WINDOWS jobs, the agent will run the job as user that was used to start the agent.  

E.g. if root started the agent, then by default all jobs will run as root, unless jobs explicitly comes with a user.

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