Clarity Throws a Network Error when session exceeds minutes of inactivity

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Article ID: 223943

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Updated On:

Products

Clarity PPM On Premise Clarity PPM On Premise

Issue/Introduction

When user is let idle exceeding the minutes of inactivity on SSO/SAML enabled clarity instance, it throws a network error instead of re-directing user to the logout page.

Cause

1. Configure Clarity with SAML 
2. Set the minutes of inactivity on Administration -> System options to 15 mins 
3. Login to Clarity Classic UI in one tab of the browser.
4. After 15 mins click on any link in the application in classic UI 


Expected Results: User should be redirected to logout page since the session is inactive and needs to be re-authenticated. 
Actual Results: We get a network error popup which doesn't go away unless we refresh the browser page.

Resolution

This is caused by Defect DE61144 and is fixed in Clarity 16.0