vmware discovery pub_queue consuming so much space
search cancel

vmware discovery pub_queue consuming so much space

book

Article ID: 223841

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The Vmware probe is continuously and increasingly consuming disk space. The current space utilization is hitting 100%. 


Specifcially the directory pub_queue contains many zipped files that increase in number and space every day. 

The path is: 

Linux: /<DXUIM_install_folder>/probes/application/vmware/discovery/pub_queue

Windows:  \<DXUIM_install_folder>\probes\application\vmware\discovery/pub_queue

 

Environment

Release : DX UIM 20.4.* / 23.4.* 

Vmware probe 7.*

Cause

The pub_queue holds QoS and other information for the discovery server. This issue appears to be correlated with large VMware environments with many VMs. The discovery folder is an internal queue that is published to the discovery server. 

Resolution

To Resolve this issue it is possible to stop these files from being created. 

 

1. Deactivate the vmware probe

2. Using IM or AC, access Raw Configure for the VMWARE probe:


Under the <setup> section,
add (or edit) the key:

debug_store_pub_queue

and set the value to false.

 

3. Activate the probe and check to ensure that the gzip files are no longer being created daily in the "/opt/nimsoft/probes/application/vmware/discovery" directory.

Additional Information

•  If after following these steps the issue is not resolved, try these steps: 

 

1. Deactivate the vmware probe

2. Using IM or AC, access Raw Configure for the VMWARE probe:


Under the <setup> section,
add (or edit) the key:

debug_store_pub_queue

and set the value to false.

4. Redeploy the same version of the VMWARE probe on top of the existing one ( no change will be added, this steps is to ensure the config file is patched correctly and does not contain any missing section or corruption) 

5. Activate the probe and check to ensure that the gzip files are no longer being created daily in the "/opt/nimsoft/probes/application/vmware/discovery" directory.

 

 

RELATED KB: 

Delete files in \<DXUIM_install_folder>\probes\application\vmware\discovery (Broadcom.com)