DBM or MTC UI won't work with ESM Microservice

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Article ID: 223412

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Updated On:

Products

CA Common Services for z/OS

Issue/Introduction

User configured ESM Microservice and the DBM/MTC UI in their maintainance system. Client cannot  login to any of the applications. Client certificates are added to keyrings as described in the documentation.

The ESM microservice log the client certificate beginning with "MIIFYzCCBEugA" is in the keyring but we do get the message, that query certificate not found in keyring.

                                                                                          
14:13:19.793 Ýhttps-jsse-nio-55110-exec-1¨ INFO  com.ca.esm.controllers.EsmStatelessControllerV2 - POST esm/v2/login                
14:13:19.794 Ýhttps-jsse-nio-55110-exec-1¨ DEBUG com.ca.esm.services.ZosCertificateService - findClientCertificate() - searching for
 query certificate '-----BEGIN CERTIFICATE-----MIIFYzCCBEugA'...                                                                    
14:13:19.794 Ýhttps-jsse-nio-55110-exec-1¨ DEBUG com.ca.esm.services.ZosCertificateService - findClientCertificate() - query certifi
cate not found in keyringÜ                                                                                                          

 

Cause

User imported the wrong client certificate in ESM microservice STC user keyring.

Environment

Release : 15.0

Component : EXTERNAL MICROSERVICE (ESM)

Resolution

Once they imported the  Correct Certificate into the keyring, the ESM microservice STC started correctly.

 

Additional Information

 As per user, the certificate was loaded per URL (https://techdocs.broadcom.com/us/en/ca-mainframe-software/traditional-management/ca-common-services-for-z-os/15-0/installing/complete-configuration-tasks/deploy-and-configure-the-esm-microservice/register-a-client-application/register-a-client-application-for-ca-top-secret.html)