autoping -S fails to a new agent - libas_c_bind.so cannot be found
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autoping -S fails to a new agent - libas_c_bind.so cannot be found

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Article ID: 223380

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Updated On:

Products

CA Workload Automation AE - System Agent (AutoSys)

Issue/Introduction

System Agent installed using the setup.bin file from the Agent iso.

An autoping -M <machine> -S command to a new agent returns an error...

CAUAJM_I_50023 AutoPinging Machine [XXXXXX]

CAUAJM_I_50031 Checking the Agent's connectivity to the Application Server.

CAUAJM_E_50037 ERROR: Agent failed to communicate with Application Server.

CAUAJM_E_50041 ERROR: Agent returned <Error loading support library - "libas_c_bind.so: cannot open shared object file: No such file or directory">.

CAUAJM_E_50281 AutoPing from the Scheduler WAS NOT SUCCESSFUL.

CAUAJM_E_50037 ERROR: Agent failed to communicate with Application Server.

CAUAJM_E_50041 ERROR: Agent returned <Error loading support library - "libas_c_bind.so: cannot open shared object file: No such file or directory">.

CAUAJM_E_50283 AutoPing from the Application Server WAS NOT SUCCESSFUL.

CAUAJM_E_50026 ERROR: AutoPing WAS NOT SUCCESSFUL.

Environment

Release : 11.4/12.0

Component : CA Workload Automation System Agent

Cause

The -S argument for autoping will check the agent's ability to connect back with the Scheduler and Application Server using Csam. If the agent is not installed using the AutoSys iso, Csam does not get installed by default. This results in the error returned from autoping with the -S argument.

Resolution

Option 1: Add an AutoSys Client to the agent machine

Option 2: Uninstall agent and then re-install it using the AutoSys iso.

Either option will result in Csam getting installed along with the agent.