UIM - Webservicemon "List Methods" button does not bring any methods or fails with Connection reset

book

Article ID: 223289

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I have installed the webservicemon probe on two servers with Windows 2012 R2. When I create a new profile in IM, I can't get to step 3 in the wizard, because the "List Methods" button does not bring any methods.

1. I see the following error in the log:  (On this server I have installed the root and intermediate certificates of the organization in the java keystore)

javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failureSep 02 18:26:08:552 [Callback_listMethodsCallBack-118, webservicemon] Unable to read the file: Received fatal alert: handshake_failureSep 02 18:26:08:556 [Callback_listMethodsCallBack-118, webservicemon] org.xml.sax.SAXParseException; Premature end of file.Sep 02 18:26:08:557 [Callback_listMethodsCallBack-118, webservicemon] java.lang.NullPointerExceptionSep 02 18:26:08:557 [Callback_listMethodsCallBack-118, webservicemon] arrMethodList : [Ljava.lang.String;@18d1e7b2Sep 02 18:26:08:558 [Callback_listMethodsCallBack-118, webservicemon] Methods found:     Sep 02 18:26:08:558 [Callback_listMethodsCallBack-118, webservicemon] < Callback [listMethodsCallBack] : Duration [17 ms] : DataSize[27 bytes] : Output:     table method_list:   

2. In other scenarios you can get to Step 4 but 'Test Request' fails with 'Response not received from the server'

The following error is captured in the log

 webservicemon] java.net.SocketException: Connection reset

Cause

This issue is most likely cause by the fact that the official available version of the probe does not support TLS 1.2. 

Environment

Release : 20.3

Component : UIM - WEBSERVICEMON

Resolution

A test fix version of the probe exists:  webservicemon_1.33_test.zip.

Deploy this version and then make a configuration change as follows to allow for TLS and test this again:

1. Insert this line at the webservicemon.cfg in the java_opt section

java_tls_ver = -Dhttps.protocols=TLSv1.2

Example:

<startup>
   <opt>
      java_opts = -Xss50M
      java_mem_max = -Xmx128m
      java_mem_init = -Xms32m
      java_tls_ver = -Dhttps.protocols=TLSv1.2
   </opt>
</startup>

2. Insert this line at the webservicemon.cfg in the setup section

protocol = TLSv1.2

Example:

<setup>
   log_input_output = 0
   defaultFileSystemPath = 
   UserAgent = CA
   ismigrated = true
   ContentType = text/xml: charset=utf-8
   proxy_enabled = no
   customSelectionValue = custom_1
   log_level = 5
   setup = 
   settings = 
   logsize = 5000
   connection_connect_timeout = 120000
   request_in_file = false
   add_custom_hotname_verifier = true
   protocol = TLSv1.2
</setup>

3. Deactivate/Activate the webservicemon probe

Additional Information

Please log a support case to request technical support to provide this fix. 

 

Related KBs:

webservicemon probe not able to get the methods list (broadcom.com)