UIM - Webservicemon "List Methods" button does not bring any methods.

book

Article ID: 223289

calendar_today

Updated On:

Products

DX Infrastructure Management

Issue/Introduction

I have installed the webservicemon probe on two servers with Windows 2012 R2. When I create a new profile in IM, I can't get to step 3 in the wizard, because the "List Methods" button does not bring any methods.

I see the following error in the log:  (On this server I have installed the root and intermediate certificates of the organization in the java keystore)

javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failureSep 02 18:26:08:552 [Callback_listMethodsCallBack-118, webservicemon] Unable to read the file: Received fatal alert: handshake_failureSep 02 18:26:08:556 [Callback_listMethodsCallBack-118, webservicemon] org.xml.sax.SAXParseException; Premature end of file.Sep 02 18:26:08:557 [Callback_listMethodsCallBack-118, webservicemon] java.lang.NullPointerExceptionSep 02 18:26:08:557 [Callback_listMethodsCallBack-118, webservicemon] arrMethodList : [Ljava.lang.String;@18d1e7b2Sep 02 18:26:08:558 [Callback_listMethodsCallBack-118, webservicemon] Methods found:     Sep 02 18:26:08:558 [Callback_listMethodsCallBack-118, webservicemon] < Callback [listMethodsCallBack] : Duration [17 ms] : DataSize[27 bytes] : Output:     table method_list:   

Cause

This issue is most likely cause by the fact that the official available version of the probe does not support TLS 1.2. 

Environment

Release : 20.3

Component : UIM - WEBSERVICEMON

Resolution

A test fix version of the probe exists:  webservicemon_1.33_test.zip.

Deploy this version and then make a configuration change as follows to allow for TLS and test this again:

Please insert this line at the webservicemon.cfg at the java_opts

java_tls_ver = -Dhttps.protocols=TLSv1.2

 

So that will be:

java_opts = -Xss50M java_mem_max = -Xmx128m java_mem_init = -Xms32m java_tls_ver = -Dhttps.protocols=TLSv1.2

Additional Information

Please log a support case to request technical support to provide this fix. 

 

Related KBs:

webservicemon probe not able to get the methods list (broadcom.com)