Oracle upgrade giving database error

book

Article ID: 223233

calendar_today

Updated On:

Products

Data Loss Prevention Oracle Standard Edition 2

Issue/Introduction

Upgrading the Oracle DB from 12 to 19, received the following error,

[WARNING] [DBT-10328] Specified GDB Name (protect) may have a potential conflict with an already existing database on the system.
   ACTION: Specify a different GDB Name that does not conflict with existing databases on the system.
[FATAL] [DBT-10317] Specified SID Name (protect) already exists.
   ACTION: Specify a different SID Name that does not already exist.

Cause

Oracle engine is installed correctly using the response file and following the guide, they tried to create the database that already exists. (Running dbca -createDatabase)

The guide does not redirect UPGRADE users back to the upgrade section once the Oracle 19 installation is complete.

 

Environment

Oracle 12.2.0.1.0

 

Resolution

Once Oracle 19 installation is complete, user should return to UPGRADE section of guide and run DBUA.