Unable to delete expired tokens and Unable to create token
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Unable to delete expired tokens and Unable to create token

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Article ID: 223212

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Updated On:

Products

CA Risk Authentication CA Advanced Authentication CA Strong Authentication

Issue/Introduction

The following errors frequently occur in the State Manager log. What can be the reason of this and how to resolve this issue?

<arcotsm.log>----------------------------------------------------------------------
2021-09-01 09:03:50,058 [Token janitor] ERROR server.tsmimpl.iBatisTSMImpl(322) [] -> Unable to delete expired tokens (issued before 20210831234849.831, used before 20210831234849.831:   
--- The error occurred in com/arcot/integrations/toksvr/server/tsmimpl/TsToken.xml.  
--- The error occurred while executing mapped statement.  
--- Check the sqlDeleteTokenOlderThan.  
--- Check the statement or the result map.  

2021-09-01 09:05:08,592 [WebContainer : 10] ERROR server.tsmimpl.iBatisTSMImpl(142) [] -> Unable to create token <Token-Value> | 20210901000508.443.9ad4a9d7: com.ibatis.common.jdbc.exception.NestedSQLException:   
--- The error occurred in com/arcot/integrations/toksvr/server/tsmimpl/TsToken.xml.  
--- The error occurred while executing mapped statement.  
--- Check the sqlInsertTokenNoRisk.  
--- Check the statement or the result map.  
---------------------------------------------------------------------------------------------

At the same time, the following error messages frequently occur in the alert log file of Oracle DB.

<alert_arcotdb.log>----------------------------------------------------------------------
Linux-x86_64 Error: 12: Cannot allocate memory
Additional information: 2673
Additional information: 884737
Additional information: 1627389952
Wed Sep 01 09:02:29 2021
Suspending MMON slave action qosdflushslv_ for 82800 seconds

ORA-01034: ORACLE not available
ORA-27102: out of memory
---------------------------------------------------------------------------------------------

We have stopped & started afm/uds/webfort/riskfort/casemgmt and are recovering.
The two systems use different AAs, the other one is not getting similar errors.

 

Environment

Release : 9.1

Component : AuthMinder(Arcot WebFort)

RiskMinder(Arcot RiskFort)

Cause

Database server is not accessible from State Manager and when it tries to look in DB table ARTSTOKENS, DB server having issues so data can not be fetched from that table.

Resolution

You will see Create Token or Delete Token failing in case where the Database is not working fine and having some issues, State Manager uses the DB connectivity parameters from the arcotcommon.ini file and if for some reason DB is not accessible then all token operations will fail. To address the issue please look at the database and make sure it is not having issues, you can refer the DB connectivity parameters from arcotcommon.ini file. This issue may also happen if there is connectivity issues from the State Manager machine to the DB machine so ensure that the State Manager is able to connect with the Database specified in arcotcommon.ini file.