Changed the IP address of IIS Webserver and re-registered the siteminder web agent but the agent is not able to connect to the Policy Server.

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Article ID: 223202

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Updated On:

Products

SITEMINDER CA Single Sign On Agents (SiteMinder) CA Single Sign On Secure Proxy Server (SiteMinder) SINGLE SIGN ON - LEGACY

Issue/Introduction

Changed the IP address of IIS Webserver and re-registered the siteminder Web Agent but the agent is not able to connect to the Policy Server.

Cause

Customer moved their Webagent environment to AWS environment and reregistered the Webagent with Policy Server since the IP address of the IIS web server got changed after moving to AWS.

Environment

Release : Any supported CA Siteminder Agent Release
Component : CA SITEMINDER (AKA CA SSO)

Resolution

They have observed that there is no LLAWP process was running and communication is NOT happening between Webagent and Policy Server.

- To troubleshoot this issue further, we have corrected the Webagent log and Webagent trace log configuration in the ACO and we have started the LLAWP process manually to confirm that there is no issue with webagent.conf, SmHost.conf files.

- When we started the LLAWP process manually, we were able to see the LLAWP process in the task manager process.

- Then we have stopped the IIS web server again by enabling the Webagent and we have observed that the LLAWP process has started running as expected and also the logs are started writing as expected.