error upgrading jasperserver from 6.2 to 6.4.3

book

Article ID: 223187

calendar_today

Updated On:

Products

CA Identity Suite

Issue/Introduction

While upgrading CABI (CA Business Intelligence) JasperReports Server from 6.2 to 6.4.3 on Windows an error was thrown.

"\ca_install\upgrade\upgrade620\export.zip' does not exist" exception.

 

Environment

Release : 14.3

Component :

Resolution

The export.zip is generated as part of the upgrade process.  This can be seen in the logs.

 

2021-08-27 09:10:05 INFO  CheckIfCABIExistsInTomcat:255 - Found required file: jasperserver-export-tool-6.2.0.jar
2021-08-27 09:20:37 DEBUG CABIAPIProcessBuilder:114 - Adding C:\Install\Upg_2021\Media\6.4.3\ca_install\GUI_Install\Windows\Disk1\InstData\VM\../../../../../..\ca_install\upgrade\upgrade620\js-export.batto arraylist
2021-08-27 09:20:37 DEBUG CABIAPIProcessBuilder:114 - Adding --everything --output-zip export.zipto arraylist


there are some known issues that can interfere with an upgrade.  Specifically, AV and file permissions.

The AV issue is documented in the Knowledge article below:

https://knowledge.broadcom.com/external/article?articleId=135902

 

Full read-write file permissions are required in the target area for the export and subsequent import to succeed.