Incorrect calculation of Agent resources when using HostGroups
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Article ID: 223183
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Updated On:
Products
CA Automic Workload Automation - Automation Engine
Issue/Introduction
When using HostGroups for Agent assignment and setting a limit on Max. Resource Jobs value it can happen that the resources are not used to the max.
Steps to reproduce:
- Jobs with the agent assignment to Host groups
- Agent maximum resources Jobs value set to any value (ex:100 or 300 or 450).
- Host Group has around multiple Agents with the mode "Load Dependent"
Issues:
- Display of full usage of resources in the Agents view when still there are resources available
- Jobs are going to "Waiting for resource" status when the actual active job count for particular agent is low.
Cause
This can happen when all jobs in a Workflow are assigned to run on the same Agent.
Environment
Release : 12.3
Component : AUTOMATION ENGINE
Resolution
In the JOBP untick:
In the JOBS choose: Generate Task at
Feedback
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