Chrome and Edge do not download PDFs from Status Reports

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Article ID: 223013

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

In order to mitigate the issue described in DE41673, it is recommended to set the Chrome/Edge options for PDF to be downloaded instead of opened by the browser.
If this option is enabled, the Modern UX Status Report may crash the browser and in the case of Edge, it cannot be downloaded at all.

Steps to Reproduce:

  1. Use Google Chrome or Microsoft Edge browser.
    Versions tested:
    Chrome 92.0.4515.159 (Official Build) (64-bit)
    Chrome 95.0.4629.0 (Official Build) canary (64-bit)
    Edge 92.0.902.84 (Official build) (64-bit)
  2. Set the browser to download the PDF files instead of opening them.
    Chrome: Settings > Site Settings > Content > Additonal content settings > PDF documents > Default behavior > Download PDFs.
    Edge: Settings > Cookies and site permissions > Site permissions > PDF documents > Always download PDF files.
  3. Set PDF to open by default with another tool (e.g.: Adobe Reader) instead of the typical Microsoft Edge default. If Edge is the default, the setting will be ignored.
  4. Open any project in the Modern UX, then go to Status > Reports > Preview.

Expected Results: Generated PDF file is downloaded. Scrolling the horizontal bar will crash the browser tab.

Actual Results: A very long text string is shown.
Specific to Chrome: An "Open" button may appear.
Specific to Edge: The "Open" button does not appear (it may still be there, but not visible as it could have a different alignment. It is not possible to download the PDF file.

Cause

This issue has been reported to Engineering as DE62391.

Environment

Release : 15.9.3

Component : CLARITY STUDIO

Resolution

This issue has been fixed in Clarity 16.0.0.