ITPAM is unable to process the SRF request with error "notApplicationUser"
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ITPAM is unable to process the SRF request with error "notApplicationUser"

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Article ID: 222852

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

ITPAM is unable to process the SRF request and getting below error:

ERROR [com.ca.pam.rest.services.startrequestforms.RestSRFsOperationService][.3.0.41-8443-10] Exception: notApplicationUser

Tried same with postman gives error:

"Pass ITPAM application user credentials"

Environment

Release : 4.3.05 CP04

Component : Process Automation

Cause

In 4.3.05 CP04 there is a change in the process that, the user should be part of the application user list to invoke the REST calls.

Resolution

Under EEM, add the user to any of the ITPAM application groups (PAMUsers group is the least required)

Additional Information

This issue is observed after applying the patch CP04 on top of 4.3.05