Boot Disk Creator - UI missing WinPE optional components
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Boot Disk Creator - UI missing WinPE optional components

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Article ID: 222817

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Updated On: 05-23-2025

Products

Ghost Solution Suite

Issue/Introduction

While creating a new or editing an existing boot disk or PXE configuration, the optional components step in Boot Disk Creator doesn't display all required packages

WinPE 10 should contain 20 to 25 optional components. However, the UI contains just a few (listed options may differ from screenshot above)

Environment

Ghost Solution Suite 3.x.x

Component:  Boot Disk Creator (bootwiz.exe)

Cause

This issue is most commonly caused by a corrupt or incomplete WinPE/ADK or optional components install

The issue may also be caused by an incomplete WinPE import to Ghost Solution Suite or Ghost Standard Tools after installation of ADK and add-ons

Resolution

This following recommendations should be taken to allow for a proper removal and reinstallation of WinPE and add-ons:

  1. Log on to the Ghost Solution Suite or Ghost Standard Tools server with an administrator account. The account should also have administrative access to the GSS console if security features are enabled

  2. Temporarily disable Windows Defender and Antivirus software or set exclusions to prevent scanning or blocking of ADK execution or install (refer to Microsoft documentation for details)

  3. Set User Account Control Settings (UAC) to 'Never notify'. The following regkey should also be set to '0' : Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System > 'EnableLUA'

  4. Open 'Programs and Features' from Control Panel and uninstall any currently installed 'Windows Assessment and Deployment Kit' as well as 'Windows Preinstallation Environment Add-ons'
  5. Open the 'Bootwiz' folder from GSS or Standard Tools installation directory (default for GSS: C:\Program Files (x86)\Altiris\eXpress\Deployment Server\Bootwiz). Open 'PreBootOs.ini' with notepad.exe or text editor. There are several versions of WinPE and LinuxPE listed in the file. Find the section with header 'WINPE100_X64'. Under this section there is an INSTALLED=True flag (indicating WinPE 10 has been imported to bootwiz). Change INSTALLED=True to INSTALLED=False for any version you would like to reimport including any installed X86 versions you want to reimport. Note: WINPE100_X64 refers to WinPE10 x64. WINPE110_X64 refers to WinPE11 x64. Don't make any modifications to the file other than changing INSTALLED= field from True to False.

  6. Open the installation directory of Ghost Solution Suite (by default C:\Program Files (x86)\Altiris\eXpress\Deployment Server) and delete the 'waik_winpeXX' folder that corresponds to the version you are reinstalling. waik_winpe10 = WinPE10, waik_winpe11 = WinPE11, etc 
  7. Download the desired version of ADK as well as its corresponding Windows PE add-on (both required)

  8. If the Ghost Solution Suite or Standard Tools server has an internet connection and can reliably download additional files required for installation, the 2 installers can be ran directly from the server. If the GSS or Standard Tools server has a limited or no internet connection, an offline install will need to be created on a computer capable of downloading the required additional files (refer to Microsoft documentation for instructions). When installing WinPE and add-ons, ensure that you right-click > run as administrator to avoid any permissions issues during file extraction. Leave the installation directory default because bootwiz will be looking for the installation in this directory.
  9. Modern WinPE/ADK versions require 2 installers to be compatible with GSS and imaging tools. Ensure that you have downloaded and installed (as administrator) both the ADK as well as corresponding version of Windows PE add-on. It doesn't matter what order these are installed in but both must be installed.

  10. Once WinPE add-ons and ADK have been installed successfully to the OS, you can then proceed to import again to Boot Disk Creator (Tools > Install Pre-Boot Operating Systems...). If directions are followed, the version you are importing shouldn't already show 'installed' in the UI.

  11. Re-enable Microsoft Defender or AV software as needed and set UAC back to desired level

  12. Create a new Boot Disk Configuration or PXE configuration and verify additional required optional components are listed