Web Service job stuck in EXEC or RUNNING state using WA Agent
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Web Service job stuck in EXEC or RUNNING state using WA Agent

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Article ID: 222659

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Updated On:

Products

CA Workload Automation DE CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation DE - Business Agents (dSeries) Workload Automation Agent

Issue/Introduction

The WS_DOCLIT jobs may stay in EXEC.  The jobs work again when agent is restarted.  This mainly happens when agent or application moved to cloud.

 

 

Environment

Release : 12.2

Component : zIIP Enablement Services

Cause

Check if either Agent or Web Service application is on cloud (Azure / AWS).  The agent constantly tries check the web service for job update.  This may result in some network / firewall appliance to time out the connections.  The following messages may be seen in the agent logs.

07/11/2021 09:21:01.262-0400 4 WebservicePlugin.webservice Internal Thread.CybWOBWebserviceRundoclitHandler.processWob[:974] - Web Service retry: null
07/11/2021 09:22:01.342-0400 4 WebservicePlugin.webservice Internal Thread.CybWOBWebserviceRundoclitHandler.processWob[:973] - Web Service timeout: null

 

 

Resolution

The appropriate ports and firewalls need to be opened.  Additionally check for any firewall rules that deny or drop connections to the WebService application.

Additional Information

Note:  If the agent was recently moved to the cloud then check if on-prem Agent has similar issues.   Contact cloud provider for more details on how traffic is managed,