DX OI - oi_connector dropping alarms - CIInformation not found for alarm

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Article ID: 222610

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Updated On:

Products

DX Operational Intelligence DX OI SaaS

Issue/Introduction

The oi_connector is unable to process specific alarms, in the oi_connector log we see messages indicating that the connector is dropping the alarms.
 
" Dropping alarm. CIInformation not found for alarm pds "
 
 
Why the oi_connector is dropping the alarms?



Cause

The above message is an indication that the device doesn't exist in the UIM database
 
By design, "Discovery " probe cache update occurs every 30 minutes, from raw configure > setup > nimbusscan
 
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You can verify if this is condition as below:
 
1) Open UIM Operator Console (OC) or Infrastructure Management (IM)
Take a note of the alarm ID from
 
2) Open MSSQL
 
3) Verify Alarm ID exist
 
select * from NAS_TRANSACTION_SUMMARY where nimid='<alarm-id>'
 
3) Verify Device exist
 
select * from nas_alarms where nimid = '<alarm_id>'
 
take a note of device name and use it in belo query:
 
select * from cm_device where dev_id = '<dev_name>'
 
for example:
 
 
If the query doesn't return anything then it means that device doesn't' exist yet in the UIM database so the OI_Connector will not be able to process the alarm ingestion request so it will drop it.

Environment

DX Operational Intelligence 20.x or SaaS

DX CA UIM - 20.3.3 + OI_Connector - 1.39

 

Resolution

Reduce the Discovery probe cache update (default 1800 = 30 minutes)
 
For example to set the update to occurs every 5 minutes, set the property = 300

Additional Information

DX Operational Intelligence Troubleshooting, Common Issues and Best Practices

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