Logging into Office 365 via Okta gives an error

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Article ID: 222566

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Updated On:

Products

CASB Security Premium CASB Gateway CASB Gateway Advanced

Issue/Introduction

Configured Mirror Gateway to work with Okta and Office 365.  After providing Okta credentials received the following error

 

Cause

Unlike other SaaS Office 365 requires an immutableID to be passed to as an Okta attribute instead of username.

Environment

Release : 1.0

Component :

Resolution

To resolve this add an attribute to the Okta SAML response with the following information.

MIGNameID     Unspecified     user.office365_immutableid

You will need to type in user.office365_immutableid as it will not show up in the drop down.

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