Agent Upgrade fails with "No space left on device"
search cancel

Agent Upgrade fails with "No space left on device"

book

Article ID: 222467

calendar_today

Updated On:

Products

Workload Automation Agent CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

Agent's setup.bin exits with 255 and install log reported error;

 

Install Uninstaller:      CA WA Agent 11.5.00.00(Install All Uninstaller Components)
                          Status: ERROR
                          Additional Notes: ERROR - Error installing uninstaller: Flexeraak1: No space left on device
                                            ERROR - Failure to install Uninstaller executable: java.lang.NullPointerException

##### SCRIPT END ############

Flexeraak1: No space left on device

###

 

 

 

 

Environment

Release : 11.5

Component : CA Workload Automation System Agent

Cause

Agent upgrade failed due to not enough space on the system /tmp directory during the upgrade process.

Resolution

Set IATEMPDIR environment variable for the agent installation program to use another temporary directory during the agent upgrade process. For example;

IATEMPDIR=/opt/CAWA/temp_dir
export IATEMPDIR

where, /opt/CAWA/temp_dir overrides the /tmp directory. 

Additional Information

Enable debugging to display more information for troubleshooting;

https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/workload-automation-system-agent/11-5/troubleshooting/troubleshooting-tips/display-debugging-information-during-agent-installation.html