SEPM Web Console it hangs at "Initializing, please wait"
search cancel

SEPM Web Console it hangs at "Initializing, please wait"

book

Article ID: 222433

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

When attempting to access Symantec Endpoint Protection Manager (SEPM) Web Console the page does not load past "Initializing, please wait".

Additionally, the Ajaxswing.log may show one of the following errors:

Thread-6 : [com.creamtec.ajaxswing.core.ClientAgentFactory$1] Exception while warming up client agent for applicaton sepm (Exception java.rmi.ConnectException, Connection refused to host: 127.0.0.1; nested exception is: 
      java.net.ConnectException: Connection refused: connect)
java.rmi.ConnectException: Connection refused to host: 127.0.0.1; nested exception is: 

or

SEVERE [https-openssl-apr-0.0.0.0-8443-exec-6] org.apache.catalina.core.StandardWrapperValve.invoke Servlet.service() for servlet [AppRouter] in context with path [/console] threw exception [Filter execution threw an exception] with root cause
java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native
at com.symantec.sepm.ajaxswing.filter.ConsoleFilter.getAvailableMemory(ConsoleFilter.java:335)
at com.symantec.sepm.ajaxswing.filter.ConsoleFilter.isMemoryAvailable(ConsoleFilter.java:382)
at com.symantec.sepm.ajaxswing.filter.ConsoleFilter.doFilter(ConsoleFilter.java:227)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:193)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:166)
at com.symantec.sepm.ajaxswing.filter.CookieEnabledCheckFilter.doFilter(CookieEnabledCheckFilter.java:84)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:193)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:166)
at org.tuckey.web.filters.urlrewrite.UrlRewriteFilter.doFilter(UrlRewriteFilter.java:738)

Environment

SEPM Version 14.3 RU10 and older

Cause

The HTTP Request to https://IP Address:8443/console/apps/sepm?do hasn't gotten a response.

Resolution

There are several possible resolutions:

  1. Verify that the server configuration doesn't restrict HTTP requests to IP Address:8443
  2. Replace the jna-4.2.2.jar:
    1. Go to SEPM server and stop the Symantec Endpoint Protection Manager Webserver service, close SEPM UI if opened
    2. Go to <SEPM_HOME>\tomcat\webapps\ajaxswing\WEB-INF\lib
    3. Take backup of, and then remove, jna-4.2.2.jar and jna-platform-4.2.2.jar
    4. Start the Symantec Endpoint Protection Manager Webserver service
  3. Upgrade to SEPM 14.4 or newer to take advantage of the new web server which includes improved web server performance and reliability