CA API Gateway - Kenna vulnerability

book

Article ID: 222425

calendar_today

Updated On:

Products

CA API Gateway

Issue/Introduction

User may see this CVE in a scan report

Kenna alert: Attached alert

CVE-2015-4000

The TLS protocol 1.2 and earlier, when a DHE_EXPORT ciphersuite is enabled on a server but not on a client, does not properly convey a DHE_EXPORT choice, which allows man-in-the-middle attackers to conduct cipher-downgrade attacks by rewriting a ClientHello with DHE replaced by DHE_EXPORT and then rewriting a ServerHello with DHE_EXPORT replaced by DHE, aka the "Logjam" issue.

 

 

 

 

Cause

TLS Version is too low in Manage Listen Ports

Environment

Release : 9.x and 10.x

 

Resolution

Disable TLS 1.0 and 1.1 in the Listen Port Properties for the relevant port 

https://techdocs.broadcom.com/us/en/ca-enterprise-software/layer7-api-management/api-gateway/10-0/security-configuration-in-policy-manager/tasks-menu-security-options/manage-listen-ports/listen-port-properties.html#concept.dita_b2bd9924f304a78cae8f4dee3631ccb27b5d47cb_ConfiguringtheSSLTLSSettingsTab