CAWA_E_20020 Logon failed Error for Windows Job
search cancel

CAWA_E_20020 Logon failed Error for Windows Job

book

Article ID: 222354

calendar_today

Updated On:

Products

CA Workload Automation AE - System Agent (AutoSys)

Issue/Introduction

A job running on a Windows agent receives a STARTJOBFAIL alarm due to the following error...

CAWA_E_20020 Logon failed for DOMAIN\USER due to: The user name or password is incorrect.. Error code: 1326

Environment

Release : 11.3.6/12.0

Component : CA Workload Automation AE (AutoSys)

Cause

This error will occur when the Scheduler sends the job owner to the Windows agent as a domain account when it is actually a local account...or vice versa. This is controlled by the presence of the "opsys: windows" attribute in the machine definition for the Windows agent. If that attribute is included, the user will be sent as a domain account. If omitted, it is sent as a local account.

Resolution

Determine whether the job owners are local or domain accounts. If they are domain accounts, make sure the machine definition for the Windows agent includes the "opsys: windows" attribute. Otherwise, make sure to omit that attribute from the machine definition.

If you have some jobs running as local accounts and others running as domain accounts on the same Windows agent, you will need to create two different machine definitions to handle them. One will be for the local accounts, and the other for the domain accounts. Use unique names in the insert_machine attribute, but make the node_name attribute the same. For example...

Machine def for local accounts...

insert_machine: windows_agent_local

node_name: windows_agent_hostname

 

Machine def for domain accounts...

insert_machine: windows_agent_domain

node_name: windows_agent_hostname

opsys: windows

 

Use the appropriate machine definition in each job based on whether the owner is local or domain.