TDM certain connection profiles that seem to be broken. The screen just refreshes when we click on a conneciont profile

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Article ID: 222339

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

 
 

The issue we are running into now is that there are certain connection profiles that seem to be broken.
While I can edit some connection profiles, there are others that I cannot.
If I click on the connection profile to edit them through TDM portal, the page simply refreshes.

I dug through the database and I have noticed that the connection profiles that I can edit will only show up once in the table 'gtrep_profile'.
However, the connection profiles that appear to be broken are showing up twice in 'gtrep_profile'.

Do you happen to have any advice on how to fix the broken connection profiles?

 

Thank you,

 

Chris Smith

Cause

 

Duplicated Connection profiles from DataMaker and the TDM Portal.

From the connection profile log I was able to find an example:
021-08-23 13:34:15.274 UTC [INFO ] [https-jsse-nio-8443-exec-2] --- [U:][M:][P:]                         o.s.w.s.DispatcherServlet:  Completed initialization in 35 ms
2021-08-23 13:34:15.740 UTC [DEBUG] [https-jsse-nio-8443-exec-2] --- [U:Administrator][M:GET][P:/api/ca/v1/connectionProfiles]                    c.c.t.c.c.ConProfileController:  RequestID: 232, Module: CONNECTION_PROFILE_MANAGER, GET /ca/v1/connectionProfiles
2021-08-23 13:34:15.752 UTC [DEBUG] [https-jsse-nio-8443-exec-2] --- [U:Administrator][M:GET][P:/api/ca/v1/connectionProfiles]                       c.c.t.c.s.ConProfileService:  getProfiles: RequestID: 232, Module: CONNECTION_PROFILE_MANAGER, UserId: 1
2021-08-23 13:34:15.799 UTC [DEBUG] [https-jsse-nio-8443-exec-2] --- [U:Administrator][M:GET][P:/api/ca/v1/connectionProfiles]                       c.c.t.c.s.ConProfileService:  getGroupProfiles: RequestID: 232, Module: CONNECTION_PROFILE_MANAGER, UserId: 1
2021-08-23 13:34:24.310 UTC [DEBUG] [https-jsse-nio-8443-exec-1] --- [U:Administrator][M:GET][P:/api/ca/v1/connectionProfiles/SQL_TDM_REQST]                    c.c.t.c.c.ConProfileController:  RequestID: 231, Module: CONNECTION_PROFILE_MANAGER,GET /ca/v1/connectionProfiles/SQL_TDM_REQST
2021-08-23 13:34:24.389 UTC [DEBUG] [https-jsse-nio-8443-exec-1] --- [U:Administrator][M:GET][P:/api/ca/v1/connectionProfiles/SQL_TDM_REQST]              c.c.t.c.e.h.GlobalExceptionConvertor:  HTTP Error - NOT FOUND: Connection profile not found.
2021-08-23 13:34:24.522 UTC [DEBUG] [https-jsse-nio-8443-exec-8] --- [U:Administrator][M:GET][P:/api/ca/v1/connectionProfiles]                    c.c.t.c.c.ConProfileController:  RequestID: 238, Module: CONNECTION_PROFILE_MANAGER, GET /ca/v1/connectionProfiles
2021-08-23 13:34:24.522 UTC [DEBUG] [https-jsse-nio-8443-exec-8] --- [U:Administrator][M:GET][P:/api/ca/v1/connectionProfiles]                       c.c.t.c.s.ConProfileService:  getProfiles: RequestID: 238, Module: CONNECTION_PROFILE_MANAGER, UserId: 1
2021-08-23 13:34:24.527 UTC [DEBUG] [https-jsse-nio-8443-exec-8] --- [U:Administrator][M:GET][P:/api/ca/v1/connectionProfiles]       

 

From the gtrep_profile table

Environment

 

TDM  4.9.1

Component : TDM Web Portal

Resolution

 
 

No conflicting Connection Profile in DataMaker and Portal:
The user was trying to access a DNS-Less connection profile in the TDM Portal, however, an ODBC connection profile with the same name already existed that was created with DataMaker.

To resolve this, first, check the connection profile in the repository with a particular name(prof_name) in the "gtrep_profile" table and delete the ODBC one that is conflicting.
This will need to be done directly in the database.

 

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