No VNA Data after drive fills.

book

Article ID: 222327

calendar_today

Updated On:

Products

CA Virtual Network Assurance

Issue/Introduction

VNA server ran out of disk space, this was resolved but we see no VNA data in Spectrum or DX Netops Performance Management 

Cause

We see the following repeated in the server.log on VNA:

YYYY-MM-DD HH:M:SS,### WARN  [org.apache.activemq.artemis.core.client] (Camel (broker-plugin-context) thread #33 - JmsConsumer[InventoryUpdateQueue]) AMQ212058: Unable to get a message.: java.lang.IndexOutOfBoundsException: Error reading in simpleString, length=####### is greater than readableBytes=#####@ClientLargeMessageImpl[messageID=######, durable=true,

Where the messageID=###### is the same id over and over again.

Environment

Release : 20.2

Component : Virtual Network Assurance For CA Performance Management

Resolution

This indicates a corrupted activemq message.

To clear the activemq cache (adjust paths for your installation directory):

systemctl stop wildfly

cd /opt/CA/VNA/wildfly/standalone/data/activemq/
tar zcvf /tmp/journal.tar.gz journal

cd /opt/CA/VNA/wildfly/standalone/data/activemq/journal/

rm *.amq

cd /opt/CA/VNA/wildfly/standalone/data/activemq/largemessages
rm *

systemctl start wildfly

This clears the activemq messages, eliminating the error.