CCS - Domain user accounts return "Account was not found in the password hash map"
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CCS - Domain user accounts return "Account was not found in the password hash map"

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Article ID: 222229

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Updated On:

Products

Control Compliance Suite Standards Server Control Compliance Suite Control Compliance Suite Standards Module

Issue/Introduction

Control Compliance Suite 12.x:

Running a data collection job or a CER job or even a query against fields such as "Password is Blank?", or "Password Is User Name?".

Results in an error such as: {BVNTMetaUser::PasswordIsEmpty() - Account "#####" was not found in the password hash map. Error : The parameter is incorrect.   Error Code = 0x00000057 (87)}

Cause

This is the result of the account having been renamed in the domain, yet the original account name still exists in the domain cache file that was built.

Resolution

To resolve this issue simply delete the domain cache files.

On each CCS Manager, stop the CCS Manager and DPS services.

Then navigate to the following location.

<installdir>\CCS\Reporting and Analytics\DPS\control\Windows\Cache\

Remove all the files located in this folder, then restart the CCS Manager and DPS services.

Now when you run your jobs, the error will no longer occur.