APIM Pod is not starting
search cancel

APIM Pod is not starting

book

Article ID: 222141

calendar_today

Updated On:

Products

CA API Developer Portal

Issue/Introduction

My portal just stop to work !

On GKE I can see the pod status 

APIM container is the one is not stating causing the problem all other container are running

Environment

Release : 5.0.2

Component : API PORTAL

Cause

rediness checks for app sync to happen is failing because of the following:

2021/08/10-19:29:30,979]-[INFO   ]-[79]-[com.l7tech.external.assertions.jdbcquery.server.ServerJdbcQueryAssertion]-9105: "Perform JDBC Query" assertion failed due to no query results via a connection OAuth

[2021/08/10-19:29:30,979]-[WARNING]-[79]-[com.l7tech.external.assertions.jdbcquery.server.ServerJdbcQueryAssertion]-9104: "Perform JDBC Query" assertion failed due to: Duplicate entry Portal API App for portal-api key Portal API Org  for key oauth_client

Resolution

portal-api key Portal API Org  for key oauth_client

Steps to solve

First need to find the UUID causing the issue from APPLICATION table name:  Portal API App for portal-api

mysql> select UUID, NAME, tenant_id from portal.APPLICATION;

Example:

mysql>select UUID, NAME, tenant_id from portal.APPLICATION;

UUID NAME TENANT

37081045-8c0b-484f-b0fe-7814f5ba343c Portal API App for tenant45 apim

Find the entry to rename/delete 

select APPLICATION_UUID, NAME, tenant_id from portal.APPLICATION_API_KEY where APPLICATION_UUID = '37081045-8c0b-484f-b0fe-7814f5ba343c';

37081045-8c0b-484f-b0fe-7814f5ba343c api key 1 apim

Then rename/update the name in the APPLICATION_API_KEY   ‘api key 1’ to something else 

UPDATE APPLICATION_API_KEY 

SET 

    name = 'new value'

WHERE

    UUID =37081045-8c0b-484f-b0fe-7814f5ba343c;

This resolved the portal started automatically after the change, If this does not work delete the key