EEM - Unable to start dxserver service as user 'dsa'
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EEM - Unable to start dxserver service as user 'dsa'

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Article ID: 222006

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Updated On:

Products

CA Workload Automation AE - Scheduler (AutoSys)

Issue/Introduction

To start EEM, the standard procedure is:

su - dsa
dxserver start all

Note: User 'dsa' is the default user name. If you selected a different user during install, 'su' to that user as they own the $DXHOME files

The service fails to start, with the following error:

# su - dsa

$ dxserver start all
Starting all dxservers
itechpoz starting
..
itechpoz failed to start
$  

As root, if you set the $DXHOME variable to $CASHCOMP/CADirectory/dxserver, the dxserver service can be started successfully. However, the service fails to start automatically upon reboot.

Environment

EEM 12.6.2

Cause

This is known to occur if the $DXHOME/bin/dxserver file has incorrect permission and ownership settings.

Resolution

You will need to ensure the $DXHOME/bin/dxserver file is owned by root:etrdir and has 4750 permissions, with the setuid bit like this:

-rwsr-x---.  1 root etrdir 7831639 Apr 18  2018 dxserver

This can be set with the following commands:

chown root:etrdir dxserver
chmod 4750 dxserver

In addition to this, if the service has previously been started as root, you will need to change the dxserver log file permissions to dsa:etrdir to allow the 'dsa' user to append to the logs.

As user 'root' :

cd $CASHCOMP/CADirectory/dxserver/logs
chown dsa:etrdir *.log

You can now su to the 'dsa' user and successfully start the dxserver service.