Uninstall WebLogic agent CLW confirmation

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Article ID: 221856

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Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

 

The other day  a WebLogic Agent was uninstalled following all the steps indicated in the documentation:
- Removed the introscope commands from the weblogic start options.
- Deleted the agent directory
- Restarted the weblogic.

And in the MoM no more data is received from that agent.

The problem comes when the command "list agents matching uninstalled_agent" is executed by clw shortly after uninstalling. When this command is executed, the agent is obtained, that is, the MoM still has it listed as an existing agent.

Why is the agent still listed as existing? How long should we wait for the agent to be unlisted?

 

Cause

 

The agent is still tracked for some time after disconnection, especially in case it was just a temporary disconnection.

Environment

Release : 10.7.0

Component :

Resolution

 
 

This value in IntroscopeEnterpriseManager.properties dictates how long the agent will be tracked by the Enterprise Manager.

introscope.enterprisemanager.autoUnmountDelayInMinutes=60

Until this time is elapsed, the agent will still appear in the CLW output.

 

 

Additional Information

 

The collector the agent was connected to should still show an Agent Connection Status metric for the agent, showing a value of 3 (disconnected) - metric sent by agent so unlikely to appear.