AM 9.3.5 Client aborts with NullpointerException Error after login

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Article ID: 221853

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

We are attempting to upgrade our AM 9.1.3 to 9.3.5.

Created the user 'keystore' and 'user_keystore_config' file as per installation document.

9.3.5 Client fails to login in local desktop with below error

JCE Initialized successfully 1475
14:05:59.568 AWT-EventQueue-0: .ClientSocketManager: keystore specified
14:05:59.607 AWT-EventQueue-0: .ErrorMsg: Error #: AwE-9999
14:05:59.608 AWT-EventQueue-0: .AxOptions: NoErrorMsgProperties=false
ErrorMsg: AwE-9999 Internal error (8/3/21 2:05 PM) 
Details: null
java.lang.NullPointerException
 at com.appworx.shared.code.server.C.B(ServerUtil2.java:160)
 at com.appworx.server.data.SocketManager.A(SocketManager.java:178)
 at com.appworx.server.data.SocketManager.<init>(SocketManager.java:126)
 at com.appworx.client.screen.util.ClientSocketManager.<init>(ClientSocketManager.java:77)
 at com.appworx.client.screen.util.Loader.setMaster(Loader.java:643)

Cause

User is being restricted even after specifying user_keystore. Permission is denied due to lack of permissions to user.

Environment

Release :9.3.5

Component : Applications Manager Client 

Resolution

- Please check user_keystore and user_keystore_config files are copied in .Appworx folder ""C:\users\<userAccount>\.AppWorx"" in desktop where Applications Manager Client is installed.

- In the above scenario, Appworx without "." folder also existed with same user_keystore files. Removed Appworx folder and Client was able to logon successfully.