An error occurred while importing Endpoint Protection client packages into the Endpoint Protection Manager

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Article ID: 221828

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Updated On:

Products

Endpoint Protection

Issue/Introduction

After a successful Endpoint Protection Manager upgrade, the client packages weren't automatically imported and when a manual import is attempted, the following error is returned:

From scm-server-0.log: (after manual import attempt)
2021-07-27 19:02:00.601 THREAD 76 SEVERE: Unexpected server error. in: com.sygate.scm.server.consolemanager.requesthandler.ProcessLuContentHandler
java.lang.IllegalStateException: Cannot add binary file for delta file: IncrementalDeltaResult [deltaFilePath=C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\Inetpub\content {01033000-6400-0000-0000-000001430200}
...

And from C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\Inetpub\content\ the following monikers are found: 

Cause

Due to missing content this caused the Endpoint Protection Manager content monikers to be corrupted preventing a client package import. 

Environment

Endpoint Protection Manager v14.3 RU2

Resolution

  1. Download the CleanMoniker.bat tool attached below.
  2. Stop SEPM services and take DB backup
  3. Copy attached bat to <SEPM_HOME>\Tools
  4. Edit the CleanMoniker.bat with the corrupt moniker name (ex: {01033000-3200-0000-0000-000001430200})
  5. Run the .bat file with command prompt as Admin
  6. Repeat steps 3-4 for any others
  7. Once all corrupt monikers are deleted
  8. Start SEPM services
  9. Manually import the client package (ex: SAV64.info / 14.3 RU2 32/64-bit package)
  10. Wait for 10 mins for package to get published in respective directories. 

Attachments

1630603663236__CleanMoniker.zip get_app