After Server Migration , Endpoints are not connecting

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Article ID: 221746

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Updated On:

Products

Continuous Delivery Director

Issue/Introduction

We have migrated the CDD from one server to another, but after migration the endpoint connectivity is still pointing to old server, giving connection refused error for all endpoints.

While configuring CDD on the new server, we have used the same Database configuration to point to the same DB. Please suggest the fix for the same issue.

Cause

With investigation it looks like your CDD server is the only one hosting the plugins and hence with movement of CDD server to a new server the plugin URL needs to be changed.

Environment

Release : 8.1

Component : Continuous Delivery Director(CONTINUOUS DLVRY DIRCTR)

Sub-Component: RACDEA : CDD ADMINISTRATION

Resolution

Please follow below steps to resolve the issue.

  • Check the settings.properties file of CDD and check for the below configuration settings
    • cdd.url.virtual_ip  should be updated to reflect the new server address of CDD.
    • cdd.plugins.automatic_discovery.url.host should be updated to reflect the new server address where plugins are hosted
  • Re-register the plugins with new server hostname/IP
  • The endpoints in the Endpoints page in CDD UI should be tested for connectivity and saved.

Additional Information

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