There is a problem accessing CA IT PAM Workflow

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Article ID: 221732

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Updated On:

Products

CA Service Management - Service Desk Manager CA Process Automation Base

Issue/Introduction

Customer tries to create or update an "Execute CA IT PAM Action" macro.

When clicking on the "CA IT PAM Definition" link to select SRF, we see the following error:

"There is a problem accessing CA IT PAM Workflow - please try again or contact the administrator. Details: ; nested exception is: javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target"

 

Another error that may appear in the jstd.log:

01/01 01:49:59.177[Thread-11] ERROR ItpamWorkflow 575 Error getting definitions:  
AxisFault
 faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
 faultSubcode: 
 faultString: java.net.SocketException: java.security.NoSuchAlgorithmException: Error constructing implementation (algorithm: Default, provider: SunJSSE, class: sun.security.ssl.SSLContextImpl$DefaultSSLContext)
 faultActor: 
 faultNode: 
 faultDetail: 
{http://xml.apache.org/axis/}stackTrace:java.net.SocketException: java.security.NoSuchAlgorithmException: Error constructing implementation (algorithm: Default, provider: SunJSSE, class: sun.security.ssl.SSLContextImpl$DefaultSSLContext)

Cause

Service Desk Manager certificate is not correct in customers keystore

Environment

Service Desk Manager 17.2.0.14

IT PAM 4.3.05

Resolution

Customer exported their certificate from CA Service Desk Manager using Firefox in .pem format.

Customer added that certificate to their nx.keystore file and recycled services, they were able to view and select SRF from ITPAM and their events began triggering properly again.

Additional Information

See also:

How to Enable Communications between Service Desk and ITPAM when ITPAM is SSL Enabled?
https://knowledge.broadcom.com/external/article?articleId=9538