Unable to enable SAML (15.9 and 15.8.1 only)
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Unable to enable SAML (15.9 and 15.8.1 only)

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Article ID: 221700

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

  • Followed the steps to enable SAML with Okta on our Clarity environment. 
  • Everything is correctly set up, Clarity SSO is enabled, SAML authentication is enabled
  • CSA and Okta are correctly set up
  • When the users try connecting, they get redirected immediately to Error URL page
    • No error message at all in logs with debug
    • No error in SAML Tracer
    • No error in DEV Tools (HTTP 302)

Environment

Release : 15.8.1, 15.9

Component : CLARITY SECURITY INTEGRATION

Cause

Running admin toggle-feature POSTUPGRADE_ON_PREMISE_SAML_FEATURE_F20836 1 did not work correctly

Resolution

1. Run the command admin toggle-feature POSTUPGRADE_ON_PREMISE_SAML_FEATURE_F20836 1

2. Check CMN_FEATURES and ensure the Enabled is set to 1

3. If not set, update it manually via SQL and commit

Note: This is a database setting so if you have done a database refresh in the meantime this can erase your settings

Additional Information

This solution is not applicable for 15.9.1 and higher as the SAML feature is enabled by default on 15.9.1+