Why rest api for 'cnt' factory is giving different results for different roles

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Article ID: 221695

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

xflow # service point fetching xaxis token incorrectly

Cause

  • Issue with Display name of the logged in user on Service Point URL
  • On login with Admin/Employee the Name shows correct
  • When logged in as Analyst , it picks the 1st inactive user and displays the name.
  • On refreshing the page the issue is cleared and the correct name is displayed.
  • Issue was reproduced on both Pre-Prod and Prod environment
  • There are some irregularities when it comes to the custom wrapper url created by Third-party
  • To differentiate with Native App or Custom we tried to repro in service point or postman
  • This was not reproduced in this scenario and working as per design.

Environment

Release : 17.3

Component : XFLOW INTERFACE FOR SDM

Resolution

This is expected behavior as per OTB environment.

If the user role is 'Employee' then the OOTB data partition which applies the constraint will take the action to show only that particular contact.

Where as for Analyst and above, there wont be any such constraint hence the results are different.