Japanese/Chinese characters in spool log are not showing Desktop Client
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Japanese/Chinese characters in spool log are not showing Desktop Client

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Article ID: 221688

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Updated On:

Products

CA Workload Automation DE Workload Automation Agent CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

Job log and spool have non-ASCII characters.   They appear garbled when the output is viewed in Desktop Client.

Environment

Release : 12.2/12.3

Component : ESP dSeries aka Workload Automation DE

Cause

The language packs or settings need to be installed on OS where DE/manager is installed.

DE relies on the local OS for localization.  It will need the language settings to properly show the UNICODE characters (Japanese/Chinese etc.).  It retrieves the spool from agent and sends it to the Desktop Client.  Check on Agent machine to make sure the spool has correct characters.

 

Resolution

In Windows, apply appropriate language pack and restart the server.

In Linux, most distros have UTF-8 enabled and cad show the CJK characters.  Check this link for more details.

Make sure that DE server, WA Agent machine and Desktop Client host all have appropriate language packs installed or enabled.