Upgrade of DSM Manager fails with MDB installation error - Error Code 110 - Pre-process failed
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Upgrade of DSM Manager fails with MDB installation error - Error Code 110 - Pre-process failed

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Article ID: 221655

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Upgrade of DSM Manager component is failing with error :

MDB installation error
Error Code: 110
Pre-process failed

 

And in file %TEMP%\ITRM\database\mdb_install\install_mdb.log following error appears :

07-13,07:58:39 Default schema of the installation user must be dbo.
07-13,07:58:39 Setupmdb_pre exit /B return code=131
07-13,07:58:39 Pre-process failed (errorlevel=131)
07-13,07:58:39 Setupmdb exit  return code=110

Environment

Client Automation 14.0 and higher

Cause

Logged User which is running the upgrade must have dbo as default schema for mdb database.

Following command should return dbo (and not NULL)

sqlcmd -S "<SQLServerName\InstanceName>" -d mdb -h-1 -Q "SET NOCOUNT ON ; SELECT default_schema_name FROM sys.database_principals WHERE principal_id = DATABASE_PRINCIPAL_ID()" -E

Resolution

Set (temporary) dbo Default Schema on mdb database for logged user in Microsoft SQL Server Management Studio :

 
1- Open Microsoft SQL Server Management Studio and connect to SQL Server
2- Go under Security - Logins
3- Right click on the logged user (or group where it belongs to) and select properties
4- In User Mapping, Set dbo Default Schema for the user on mdb database

 

After upgrade this settings could be removed.