Symantec Identity Manager - After upgrading to 14.4 or 14.3 CP2 null pointer exception is being thrown during provisioning tasks
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Symantec Identity Manager - After upgrading to 14.4 or 14.3 CP2 null pointer exception is being thrown during provisioning tasks

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Article ID: 221481

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

After upgrading to 14.4 or 14.3 CP2 null pointer exception is being thrown during provisioning tasks.

ERROR [im.provisioning] (Thread-29 (ActiveMQ-client-global-threads)) java.lang.NullPointerException
ERROR [com.netegrity.ims.exception.EventExecuteStateException] (Thread-29 (ActiveMQ-client-global-threads)) Execution of event: ModifyActiveDirectoryAccount failed.  Exception encountered: java.lang.NullPointerException
ERROR [com.netegrity.ims.businessprocess.IMSEventController] (Thread-29 (ActiveMQ-client-global-threads)) Error during event execution [bcb89e9a-0a1146be-6ce1f4b6-d7932b71] ModifyActiveDirectoryAccount

Environment

Release : 14.3CP2 and 14.4

Component : IdentityMinder(Identity Manager)

Cause

In 14.4 and 14.3CP2, Provisioning Load Balancing was introduced. If you had any inflight tasks during the upgrade and then enabled Provisioning Load Balancing within the Directory.xml then IDM will not know which Provisioning Server to send the request to. As such when you go into View Submitted Task, at the top left you will see "Provisioning Server: not available".

Resolution

Open a support case and have them provide you the hotfix from DE509304 or request a more recent HF.

This issue may also be resolved in 14.3CP3 and 14.4CP1 and if at such time these CP's are available, please upgrade to those CP's.