Gatelet App Invision app does not Give an Upload Failure Message on a Blocked Upload
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Gatelet App Invision app does not Give an Upload Failure Message on a Blocked Upload

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Article ID: 221435

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Updated On:

Products

CASB Gateway CASB Gateway Advanced CASB Security Standard CASB Security Advanced CASB Security Premium CASB Security Premium

Issue/Introduction

Invision App does not provide a failed upload message when a file is blocked by a DLP policy.

The Invision APP SaaS spins as if it is waiting for the upload to finish when the upload has failed.

End users are confused as to what happened with their upload.

 

 

Cause

The CASB\DLP Block happens as the Elastica gateway sends a http response to the Invision app instead of transmitting the file.

The Invision app is responsible to interpret a failed upload condition and report it back to the browser.

Resolution

SWG Agent offers a BSN (Block Service Notification) that can be enabled by contacting support.

Screenshot: (Invisionapp spinning on upload with the SWG BSN.)

The SWG BSN can be enabled on a per tenant bases by request through Broadcom SWG Support.

Additional Information

This issue could potentially happen with any SaaS that does not honor 3xx / 4xx  Http response codes.