Upgrade from 12.6.8 to 14.4

book

Article ID: 221400

calendar_today

Updated On:

Products

CA Identity Manager

Issue/Introduction

Is it possible to upgrade directly from CA Identity Manager 12.6.8 (on-premise) hosted on Wildfly 8.2 to Symantec (IGA) Identity Manager 14.4?

 

Environment

Release : 12.6.8 -> 14.4

Component : IDENTITY MANAGER (IdentityManager)

Resolution

The best upgrade route is to go from 12.6.8 to 14.3 CP2, as this will support both Wildfly 8.2 and 15.  Then migrate the Wildfly deployment to 15 and then upgrade 14.3 CP2 to 14.4

Please note: that you need to upgrade to 14.3 CP2, you cannot cust corners by jumping from 14.3 GA to 14.4 as there are some schema changes in 14.3 CP2 that are required for a successful upgrade to 14.4

There are also some caveats to upgrading from 12.6.8 which are discussed in the product documentation (link below) 

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-manager/14-4/Release-Notes/upgrade-considerations.html