Auto ticketing stops working after restart of Nimsoft and Service Desk
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Auto ticketing stops working after restart of Nimsoft and Service Desk

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Article ID: 221363

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Updated On:

Products

CA Service Desk Manager

Issue/Introduction

Sdgtw.log shows the following errors:

ServiceDesk mdr_id :CASDM

In validateIntegration method :url is http://localhost:57840/ca-nim-sm/api/v2/config/integration/CASDM/testConnection

going to call parseResponse ::: URL ::MDR http://localhost:57840/ca-nim-sm/api/v2/config/integration/CASDM/testConnection :: CASDM

responseCode :: [200] response message :: [OK]

Exception in making the connection to MDR:java.lang.NullPointerException

                at com.nimsoft.probe.gateway.sdgtw.SDGtwProbe.initiateAlarmSynchronizer(SDGtwProbe.java:272)

                at com.nimsoft.probe.gateway.sdgtw.SDGtwProbe.initializeAndConfigureNim(SDGtwProbe.java:172)

                at com.nimsoft.probe.gateway.sdgtw.SDGtwProbe.access$000(SDGtwProbe.java:70)

                at com.nimsoft.probe.gateway.sdgtw.SDGtwProbe$1.run(SDGtwProbe.java:132)

                at java.lang.Thread.run(Thread.java:745)

 Done with CASDM

Done with Alarm Synchronization

Queue is NOT SUBSCRIBED as there is no valid Service Desk connection. Please check Service Desk connection details or configure service desk(s)

Nim.log also reports:

ERROR sdm.CASDMWebService: Retry message %s with exception Error invoking web service 'getAccessKey' operation.  Retrying 2/2 ...

ERROR sdm.CASDMWebService: CA SDM method 'getAccessKey' was not successful

ERROR sdm.CASDMProvider: Problem with 'getIncidents';  Printing stack trace if available: null

The SDM integration is configured correctly, as per DX UIM - SDM Validation failed error.

Environment

  • CA Service Desk 17.3.X
  • NIMSOFT 20.x (PROBE sdgtw version 2.x)

Cause

The user that connects to SDM is put in a Data Partition that did not have access to the appropriate info

Resolution

  1. Ensure the user that connects to SDM in a Data Partition has access to the appropriate info.
  2. Also, check the NX.env for the following:
    1. @NX_REST_WEBSERVICE_DISABLE_BASIC_AUTH=No

      It should also be enabled in the Options Manager.
    2. After verifying this, if changes are required, perform the following after making the appropriate changes.

      pdm_tomcat_nxd -c STOP -t REST

      pdm_tomcat_nxd  -c START -t REST