Console slow to load homepage, reports or logs with limited admin account, eventually the session will time out
search cancel

Console slow to load homepage, reports or logs with limited admin account, eventually the session will time out

book

Article ID: 221294

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

After upgrade to 14.3 RU2, limited admin account users are not able to login and use the console without poor performance.  The console is very slow to load the homepage, reports, or export any logs.  There is no errors logged and eventually the logged in session will timeout.  This affects the local console, web console and the java console, when logged in as a limited admin.  When logged in as an admin account, there is not the same performance issue experienced.

Environment

  • 14.3 RU2 SEPM
  • Limited Admin account
  • Large number of client groups in the thousands

 

Cause

Refactoring of the code in 14.3-RU2 caused the $global_user_id not to be set even before the first usage in connectdb. This eventually caused the SQL IN operator to be used with the permitted Group IDs in the queries for limited admin user, instead of using SQL IN clause on the ADMIN_GROUPS table.

Resolution

This issue is fixed in Symantec Endpoint Protection 14.3 RU3.  For information on how to obtain the latest build of Symantec Endpoint Protection, see Download the latest version of Symantec Endpoint Protection.